Tutorial Mikrotik com BFW3.x e Squid3.4 ou + by expertinfo

Tutoriais BrazilFW 3.x em Português

Tutorial Mikrotik com BFW3.x e Squid3.4 ou + by expertinfo

Mensagempor reginaldo » Ter Mai 09, 2017 8:44 pm

Squid 3.4 ou Superior em paralelo com o Mikrotik no BrazilFW 3.0.262
  • O autor tanto deste Tutorial quanto do vídeo é o expertinfo :o! :aplause:

Simulando um cenário com três interfaces:
    Ether1 = ether1_Internet (Link de Internet)
    Ether2 = ether2_Local (Rede Local)
    Ether3 = ether3_Cache (Servidor Brazilfw com Squid 3.5)

Endereços atribuidos:
    ether2_Local (Rede Local): 192.168.30.1/24
    ether3_Cache (Servidor Brazilfw): 192.168.100.1/30

Definir endereço ip do BFW no Mikrotik:
Código: Selecionar todos
/ip address
add address=192.168.100.1/30 comment=Cache disabled=no interface=ether3_Cache \
    network=192.168.100.0


Regras NAT no Mikrotik:
Código: Selecionar todos
/ip firewall nat
add action=masquerade chain=srcnat disabled=no src-address=192.168.100.0/24
add action=redirect chain=dstnat comment="redirecionar para o proxy" \
    disabled=yes dst-address=!192.168.100.2 dst-port=80 protocol=tcp \
    src-address=!192.168.100.2 to-ports=5128


Regras Firewall Filter:
Código: Selecionar todos
/ip firewall filter
add action=accept chain=forward comment="Cache BFW" disabled=no src-address=\
    192.168.100.0/30


Regras Proxy:
Código: Selecionar todos
/ip proxy
set always-from-cache=no cache-administrator=BrazilFW cache-hit-dscp=4 \
    cache-on-disk=no enabled=yes max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
    parent-proxy=192.168.100.2 parent-proxy-port=3128 port=5128
    serialize-connections=no src-address=0.0.0.0\

Obs.
O ip do parent-proxy é o que foi atribuído ao BrazilFW.


Vídeo com os passos no BFW para coloca-lo em paralelo com o Mikrotik.https://www.youtube.com/watch?v=bPCiFxaOyyM


Dúvidas? » https://www.brazilfw.com.br/forum/viewtopic.php?f=75&t=93651&p=343491#p343491
Contribua para que o Projeto BFW permaneça no ar, Doe Click aqui
Contribua com o reginaldo, Doe, favor enviar e-mail para reginaldo@brazilfw.com.br
-----------------------------------------------------------------------------------------------------
"Disciplina é liberdade. Compaixão é fortaleza. Ter bondade é ter coragem" (Há Tempos [Dado Villa-Lobos/Renato Russo/Marcelo Bonfá])
Avatar do usuário
reginaldo
BFW Mediator
BFW Documenter
BFW Manager
BFW 3.x Update
 
Mensagens: 12682
Registrado em: Sáb Ago 27, 2005 12:10 pm
Localização: Rio de Janeiro - RJ
BrazilFW Box: Máquina Física
CPU: Intel Core i3 Model 530
Memória: 8.00 GiB / 2 Links
BFW 3.0.262 64 bits
Serviços Ativos: Control MAC, QOS
Addons: EBackup, EPM e Squid 3.5.x

Voltar para BrazilFW 3.x

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante