Navegação ficando lenta e trava

Fórum em português destinado a discussões gerais e ajuda aos usuários do BrazilFW 3.x

Navegação ficando lenta e trava

Mensagempor Helder » Qui Fev 13, 2020 11:27 am

Bom dia a todos.

Situação:
Rede com 25 computadores, escritório de contabilidade.
Usa lista branca com DansGuardian e bloqueio de HTTPS via WPAD.
A instabilidade começou faz alguns meses. Os acessos às áreas de trabalho remotas e o acesso ao ambiente de configuração via web do BrazilFW continuam acessíveis, não sofrem interferência, ou seja a Internet está ok. A navegação nos sites que vai ficando lenta aos poucos até travar.
Desconfio do Squid, ao reiniciar o cache a navegação volta normal, mas depois de um tempo começa a degradar novamente.

De uns anos para cá muitos serviços contábeis estão cada vez mais dependentes da Internet, suspeito que as especificações do hardware atual já não seja mais suficientes:

PC Lenovo, Intel(R) Pentium(R) CPU G2030 @ 3.00GHz, 8GB RAM, HD SSD 120GB, 1 link Embratel 10Mbps

Preciso de uma recomendação de configuração hardware recomendável para o servidor do BrazilFW supondo que a quantidade de computadores duplicará.
São bem-vindas também sugestões de alteração das configurações do BrazilFW.


Seguem as especificações atuais:

Versão BFW: 3.0.262
Arquitetura: 64 bits
Serviços Ativos: DNS, DHCP, Cache em disco, Filtro de Conteúdo.
Add-ons instalados: DansGuardian (nativo)
Cache de Disco está ativado, se sim qual versão? Está ativado, versão nativa que vem com o BFW 3.0.262
Arquivos nativos que foram modificados: Suponho aqui que seriam particularidades para quem "fuça" além do que está exposto via interface web do BFW, logo, nenhum.

Não fui o único a configurar o BrazilFW, vão aqui os arquivos de configuração:

hosts.cfg está vazio
qos.cfg está vazio
route.cfg está vazio
rc.local está vazio

File: brazilfw.cfg
WEBADMIN_PORT='****apaguei aqui antes de postar no forum****'
SSH_PORT='****apaguei aqui antes de postar no forum****'
ADMIN_AUTH='****apaguei aqui antes de postar no forum****'
DNSSERVER='yes'
HOSTNAME='brazilfw'
DNS1='8.8.8.8'
DNS2='8.8.4.4'
PERSIST_LOG='no'
PARTITION=''
TIME_ZONE='America/Sao_Paulo'
CACHE_DISK='yes'
USE_QOS='no'
DHCP_SERVER='yes'
DHCP_DEFAULT_LEASE='7200'
DHCP_DNS1=''
DHCP_DNS2=''
IPUPDATE='no'
IPUPDATE_REFRESH='600'
USE_MAC_CONTROL='no'
CERTIFICATE_ISSUED_TO=''
EXTERNAL_PING='yes'
ENABLE_MYSQL='no'
ARP_SCAN_RETRY='1'
ARP_SCAN_TIMEOUT='250'
KEYBOARD='br-abnt2'
DNSFREECHOICE='no'
USE_RESTRICTION_FILE='no'
SHOW_LINK_USAGE='yes'
DMZ=''
ADDON_EXPERIMENTAL='no'
DISTRO_EXPERIMENTAL='no'
WPAD='yes'


File: cron.cfg
0 0 * * * /etc/rc.d/rc.time >/dev/null 2>&1
0 0 * * * /etc/init.d/squid rotate


File: reserve.cfg
192.168.100.3 00:15:60:95:5D:41 #'****apaguei aqui antes de postar no forum****'
192.168.100.4 64:1c:67:8e:1b:fc #'****apaguei aqui antes de postar no forum****'
192.168.100.9 f4:8e:38:df:ac:a5 #'****apaguei aqui antes de postar no forum****'
192.168.100.50 00:19:BB:D1:68:21 #'****apaguei aqui antes de postar no forum****'
192.168.100.14 00:04:00:A5:B5:93 #'****apaguei aqui antes de postar no forum****'
192.168.100.30 00:17:61:10:08:A9 #'****apaguei aqui antes de postar no forum****'
192.168.100.27 B8:CA:3A:FC:4C:59 #'****apaguei aqui antes de postar no forum****'
192.168.100.25 00:14:D1:8B:80:78 #'****apaguei aqui antes de postar no forum****'
192.168.100.31 64:1C:67:6A:B8:66 #'****apaguei aqui antes de postar no forum****'
192.168.100.23 64:31:50:A6:CD:59 #'****apaguei aqui antes de postar no forum****'
192.168.100.22 00:23:24:3B:1C:36 #'****apaguei aqui antes de postar no forum****'
192.168.100.38 F4:8E:38:E0:74:AF #'****apaguei aqui antes de postar no forum****'
192.168.100.19 a4:1f:72:f4:3d:c6 #'****apaguei aqui antes de postar no forum****'
192.168.100.21 00:26:55:25:42:18 #'****apaguei aqui antes de postar no forum****'
192.168.100.45 30:05:5C:E9:39:CD #'****apaguei aqui antes de postar no forum****'
192.168.100.47 64:1c:67:8b:fa:71 #'****apaguei aqui antes de postar no forum****'


File: /etc/brazilfw/physical/local
INTERFACE_TYPE="cabled"
INTERFACE_PHYSICAL="eth0"


File: /etc/brazilfw/physical/internet
INTERFACE_PHYSICAL='eth1'
INTERFACE_MAC=''
INTERFACE_NEGOTIATION='Auto'
INTERFACE_TYPE='cabled'


File: /etc/brazilfw/logical/local
LINK_TYPE='static'
LINK_CONNECTION='local'
LINK_ALIAS='local'
LINK_IP='192.168.100.1'
LINK_NETMASK='255.255.255.0'
LINK_ADDITIONAL_IP=''


File: /etc/brazilfw/logical/internet
LINK_TYPE='static'
LINK_CONNECTION='internet'
LINK_ALIAS='internet'
LINK_IP='192.168.1.100'
LINK_NETMASK='255.255.255.0'
LINK_GATEWAY='192.168.1.1'
LINK_WEIGHT='1'
LINK_UPSTREAM='0'
LINK_DOWNSTREAM='0'
LINK_MTU='1472'
LINK_LOADBALANCE='yes'
LINK_PERSISTENT='no'
LINK_ADDITIONAL_IP=''
LINK_NAT='yes'


File: /etc/brazilfw/custom/squid.cfg
MAXIMUM_OBJECT_SIZE='500000'
MAXIMUM_OBJECT_SIZE_MEMORY='512'
MAXIMUM_CACHE_SIZE=''
MAXIMUM_RAM_CACHE_SIZE='16'
WEB_CONTENT_FILTER='yes'
SQUID_REPORT='no'
REPORT_DELETE_AFTER_DAYS='0'
RUN_REPORT_PERIODIC='yes'
CACHE_LOG='yes'
TPROXY='no'
HIDE_PROXY='no'
INTERCEPT='no'
SQUID_PARTITION='/partition'
LOG_PARTITION='/partition'
REPORT_FOLDER='/partition'


File: /etc/brazilfw/custom/squid.out
vitoria.es.gov.br #Pref. Vitoria
atendimentovirtual.sistemas.cesan.com.br
faesa.br #Faesa


Não sei se convém colocar aqui a lista do DansGuardian. Como dito anteriormente, usa lista branca, tudo bloqueado exceto 780 endereços.
Também na lista Configurações->Firewall-NAT há 658 registros.

Agradeço desde já.
Avatar do usuário
Helder
BFW Curious
 
Mensagens: 5
Registrado em: Seg Fev 10, 2020 3:31 pm
BrazilFW Box: PC Lenovo, Intel(R) Pentium(R) CPU G2030 @ 3.00GHz, 8GB, HD SSD 120GB, 1 link Embratel 10Mbps
BFW 3.0.262, 64 bits
Lista branca de http com DansGuardian e https com Squid + WPAD.

Re: Navegação ficando lenta e trava

Mensagempor Lenobare » Dom Mar 15, 2020 1:53 pm

Para seu caso:
MAXIMUM_RAM_CACHE_SIZE='16' \/
MAXIMUM_RAM_CACHE_SIZE='3072' :D

Instale o squid 3.5.27:
https://www.brazilfw.com.br/forum/viewtopic.php?f=57&t=94433#p346333

SSD de verdade custar 50k portanto recomendo um HD SCSI ou preferencia um SAS, mas seu SSD resolve os 25 usuarios.
Se sua fonte for menos que 350w ou 400w, pense em mudar para um valor de 500w pelo menos

Migre seu processador para um i3 mas recomendo pelo menos um i5 pra cima
Se for migrar para um servidor físico, recomendo Xeons como o HP Proliante G6 ou superior, DELL T110 ou superior, ou seja, destas linhas pra cima.

Reporte seus resultados por favor.
Estude, estude e... continue estudando.
Avatar do usuário
Lenobare
BFW Full Associate
BFW Beneméritos
BFW Manager
BFW Moderator
BFW HaarpCache
BFW Squid 3.5.x
 
Mensagens: 1669
Registrado em: Qua Ago 28, 2013 8:45 pm
Localização: Brasília
BrazilFW Box: Maquina: Fisica
CPU:Xeon HP ML30
Memória 8GB - 2Links
BFW 3.0.262 64 Bits
HD 300GB 15k,
Serviços Ativos: Control Mac, VPN, Squid (Cache),
Addons: Haro, Whatchdog. Squid 3.5.27, Lognet e Samba.

Re: Navegação ficando lenta e trava

Mensagempor Helder » Qui Abr 16, 2020 3:33 pm

Infelizmente o Covid-19 interrompeu as atividades e redirecionou as prioridades, terei que esperar a onda passar e aguardar as novas decisões tomadas. Mas vai ficar guardado na agenda. :-(
Avatar do usuário
Helder
BFW Curious
 
Mensagens: 5
Registrado em: Seg Fev 10, 2020 3:31 pm
BrazilFW Box: PC Lenovo, Intel(R) Pentium(R) CPU G2030 @ 3.00GHz, 8GB, HD SSD 120GB, 1 link Embratel 10Mbps
BFW 3.0.262, 64 bits
Lista branca de http com DansGuardian e https com Squid + WPAD.


Voltar para BrazilFW 3.x - Ajuda em Geral

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 7 visitantes

cron