ROTAS e PORTAS

Fórum em português destinado a discussões gerais e ajuda aos usuários do BrazilFW 3.x

ROTAS e PORTAS

Mensagempor lealis » Sáb Ago 17, 2019 12:46 pm

Olá pessoal, pesquisei bastante aqui no forum e desisti pois não sei nem o nome do que preciso no BFW

Preciso que a rota destino de IP X que sai na porta 80 vá para o IP Y porta 80
Preciso que esse mesmo IP X que sai na porta 443 vá para outro IPW porta 3128.

NO Mikrotik fica assim

/ip firewall nat
add action=dst-nat chain=dstnat comment=IP_bypass dst-address=\
200.200.200.200 dst-port=80 protocol=tcp to-addresses=222.222.222.222 src-address=\
192.168.1.51
add action=dst-nat chain=dstnat comment=ccboot_https_bypass dst-address=\
200.200.200.200 dst-port=443 protocol=tcp to-addresses=111.111.111.111 to-ports=3128 src-address=\
192.168.1.51
Avatar do usuário
lealis
BFW Curious
 
Mensagens: 6
Registrado em: Dom Mar 19, 2017 8:54 pm
BrazilFW Box:

Re: ROTAS e PORTAS

Mensagempor the-mask » Qui Ago 22, 2019 10:32 am

Salve lealis,

Ando meio enferrujado mas acho que fica assim:

Código: Selecionar todos
iptables -t nat -A PREROUTING -p tcp -s 192.168.1.51 -d 200.200.200.200 -j DNAT --to 222.222.222.222
iptables -t nat -A PREROUTING -p tcp -s 192.168.1.51 -d 200.200.200.200 --dport 443 -j DNAT --to 111.111.111.111:3128


Abraços.
Avatar do usuário
the-mask
BFW Participative
 
Mensagens: 106
Registrado em: Qua Fev 20, 2013 11:56 am
Localização: Belém - Pará - Brasil
BrazilFW Box: Host -> I5-2310 2.80 GHz - 4 GB RAM - 500 GB HDD - Linux Mint 17.1 Cinnamon
Gateway -> Celeron 430 1.80GHz - 1GB RAM - 40 GB HDD - BFW 3.0.258 - DNS, Cache, DHCP, QOS, Webserver, Samba

Re: ROTAS e PORTAS

Mensagempor lealis » Sex Ago 23, 2019 12:36 pm

the-mask escreveu:Salve lealis,

Ando meio enferrujado mas acho que fica assim:

Código: Selecionar todos
iptables -t nat -A PREROUTING -p tcp -s 192.168.1.51 -d 200.200.200.200 -j DNAT --to 222.222.222.222
iptables -t nat -A PREROUTING -p tcp -s 192.168.1.51 -d 200.200.200.200 --dport 443 -j DNAT --to 111.111.111.111:3128


Abraços.


Amigo, quase isso!! Sua luz me ajudou a chegar no resultado que funcionou!!!!!!!
O que funcionou perfeitamente foi
iptables -t nat -A PREROUTING -p tcp -s 192.168.1.51 -d 200.200.200.200 --dport 1:63516 -j DNAT --to 222.222.222.222
iptables -t nat -A PREROUTING -p tcp -s 192.168.1.51 -d 200.200.200.200 --dport 443 -j DNAT --to 111.111.111.111:3128

Feito, agora é só adicionar /etc/bfrazilfw/custom/rc.local - caso contrário se perde a cada reboot
Avatar do usuário
lealis
BFW Curious
 
Mensagens: 6
Registrado em: Dom Mar 19, 2017 8:54 pm
BrazilFW Box:

Re: ROTAS e PORTAS

Mensagempor robsonzornitta » Seg Jun 29, 2020 2:28 pm

Pergunta boba kkkkkkkkkkkk

Por acaso essas regras são para barrar 443 ou https fora do proxy e redirecionar direto pro squid?
Seja Livre! Use Linux!
Avatar do usuário
robsonzornitta
BFW Very Participative
 
Mensagens: 306
Registrado em: Ter Ago 10, 2010 10:36 pm
Localização: Curitiba - Paraná
BrazilFW Box:

Re: ROTAS e PORTAS

Mensagempor Lenobare » Qui Jul 02, 2020 4:46 pm

Só dá pra barrar o 443 por iptables ou WPAD. Rotas não bloqueiam nada, só redirecionam.
No caso, o iptables redirecionou a porta para 443 a 3128 do squid, que é praticamente um wpad.
Mas é uma forma interessante de controle, boa dica.
Estude, estude e... continue estudando.
Avatar do usuário
Lenobare
BFW Full Associate
BFW Beneméritos
BFW Manager
BFW Moderator
BFW HaarpCache
BFW Squid 3.5.x
 
Mensagens: 1669
Registrado em: Qua Ago 28, 2013 8:45 pm
Localização: Brasília
BrazilFW Box: Maquina: Fisica
CPU:Xeon HP ML30
Memória 8GB - 2Links
BFW 3.0.262 64 Bits
HD 300GB 15k,
Serviços Ativos: Control Mac, VPN, Squid (Cache),
Addons: Haro, Whatchdog. Squid 3.5.27, Lognet e Samba.


Voltar para BrazilFW 3.x - Ajuda em Geral

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 4 visitantes

cron