Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Fórum destinado a discussões gerais e ajuda aos usuários do BrazilFW 2.x, para os idiomas (Inglês, Espanhol, Português e outros)
BrazilFW 2.x - Ayuda en general (todos los idiomas)
Foro de discusión general y ayudar a los usuarios BrazilFW 2.x para idiomas (Inglés, español, portugués y otros)
BrazilFW 2.x - Help in General (All Languages)
Forum for general discussions and help for users of BrazilFW 2.x, for languages (English, Spanish, Portuguese and others)

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor hugoconnect » Sex Out 03, 2008 9:58 am

eduarley escreveu:Para os desenvolvedores....

Esta questao da lentidao no 2.31.10 sera resolvido em uma versao 2.31.1x ou so na 3.0? Vai de morar muito ainda para lancar a versao 3.0?

ou vou ter ki instalar a vesao 2.30.1....?

estou em duvida pq quando usava o mikrotikem um pc vi que era bem mais rapido pra abrir as paginas.....



Salve.

E assim cara .. esta tudo em fase de teste 3 noites pensando para resolver o problema.. estamos empenhado para ajudar!! todos so que .. nao temos data e nein possibilidade. de falar quando iremos salvar vc

instalar a versao 2.30.1 fica a vontade ou mesmo vc faz um mk tb para te salvar . .Tudo aki e feito em forma de ajuda entao temos que aguardar!!!

Obrigado
Avatar do usuário
hugoconnect
BFW Very Participative
 
Mensagens: 438
Registrado em: Sáb Dez 30, 2006 2:58 pm
Localização: acreuna - Goiás
BrazilFW Box:

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor eduarley » Sex Out 03, 2008 10:44 am

Marcos do Vale escreveu:Amigo,

A pior coisa que pode acontecer quando estamos com problemas e nos encontramos na fase de tentar resolver é aparecer alguém perguntando quando é que vai ficar pronto.

Desculpe-me a franqueza ... mas segura a onda, ok.


ME Desculpe cara nao queria ser mal entendido... sou novo por aki estou aprendendo muito... pq eu estou desesperado o que fazer entende... meus clientes estao reclamando quero saber se conpensa instalar a versao 2.30.1 pois tenho que fazer a escolha certa.. mas eu tenho certeza que o bfw e melhor do que o mk.. so num estou acostumado com ele ainda....
eduarley
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Namor » Sex Out 03, 2008 11:59 am

eduarley escreveu:
Marcos do Vale escreveu:Amigo,

A pior coisa que pode acontecer quando estamos com problemas e nos encontramos na fase de tentar resolver é aparecer alguém perguntando quando é que vai ficar pronto.

Desculpe-me a franqueza ... mas segura a onda, ok.


ME Desculpe cara nao queria ser mal entendido... sou novo por aki estou aprendendo muito... pq eu estou desesperado o que fazer entende... meus clientes estao reclamando quero saber se conpensa instalar a versao 2.30.1 pois tenho que fazer a escolha certa.. mas eu tenho certeza que o bfw e melhor do que o mk.. so num estou acostumado com ele ainda....



Em matéria de velocidade a 2.30.1 está mais rápida (porem menos interativa) faltam algumas bibliotecas e outras coisinhas.

Estou usando ela agora, mas gostei muito da instalação da 2.31.10, espero mesmo que vejamos uma resposta logo.

Mas amigo "por enquanto" use a 2.30.1 ela está mais rápida mesmo.
Namor
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor jerelogan » Sex Out 03, 2008 3:30 pm

luapufo escreveu:Minha configuração esta assim:
BFW LAN = 192.168.0.1
QOS, SUBREDE, FIREWALL, APACHE, etc ..
Tirei fora, SQUID, SARG, MARADNS e não uso LOADBALANCE.

ping de uma maquina na faixa do BFW com QOS habilitado disparando para a LAN do BFW.
Imagem

Ping de uma maquina na faixa do BFW com QOS desabilitado disparando para a LAN do BFW.
Imagem

Ping de uma maquina em uma subrede do BFW com QOS PARA SUB-REDE habilitado disparando para a LAN do BFW.
Imagem

Ping de uma maquina em uma subrede do BFW com QOS PARA SUB-REDE desabilitado disparando para a LAN do BFW.
Imagem

Ping de uma maquina em uma subrede do BFW com QOS Geral habilitado para Sub-Rede e na opção de subrede o QOS habilitado disparando para o Gateway da Sub-Rede.
Imagem

Ping de uma maquina em uma subrede do BFW com QOS Geral habilitado para Sub-Rede e na opção de subrede o QOS desabilitado disparando para o Gateway da Sub-Rede.
Imagem

Ping de uma maquina em uma subrede do BFW com QOS Geral Desabilitado para Sub-Rede disparando para o Gateway da Sub-Rede.
Imagem

Ping de uma maquina em uma subrede do BFW com QOS Geral Desabilitado para Sub-Rede disparando para a LAN do BFW.
Imagem

qualquer duvida estamos ai, navegação normal, mais jogos podem apresentar problema se estiver com trafico alto


Boa tarde luapufo;

Quero te parabenizar pelo teste q vc fez, eu fiz a mesca coisa q vc, depois de ve seu post é claro, rsrs. E foi exatamente o mesmo valor, o q entendi é q o qos esta fazendo com q o ping bata alto, quando ele esta desabilitado o ping vai normal.

Testei com Sube rede qos geral desabilitado e qos pra rede abilitado, um abraço.
jerelogan
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor eduarley » Dom Out 05, 2008 9:29 am

Então o problema pode esta no QOS?

a ki eu num uso qos no bfw e sim em ums serve em cascata mikotik!!!
eduarley
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Juanillo » Dom Out 05, 2008 11:14 am

Nao, acho que o problema nao e QOS ... eu uso BFW + SQUID sim QOS e a 2.30.1 e bem mais rapida que o 2.31.10
Juanillo
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor tecjair » Dom Out 05, 2008 6:27 pm

Luapufo e jerelogan, quais as versões testadas?? As duas em questão??
BrazilFW 3.0 64bits O Imbatível!
Linux User: #431158
BrazilFW User: #2624
Contribua com o Projeto, Doe Click aqui
Contribua com o Woshman, Doe Click aqui
Avatar do usuário
tecjair
BFW Add-on Developer
BFW Beneméritos
BFW Team
BFW Expert
BFW 3.x Update
 
Mensagens: 1091
Registrado em: Dom Nov 12, 2006 7:44 pm
Localização: Camaçari - Bahia - Brasil
BrazilFW Box: BFW 3.0 64Bits
Intel(R) Core(TM)2 Duo CPU E7200
Memória: 4 GB
HD: 500GB

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Val » Ter Out 07, 2008 7:42 pm

Hummm!!!! \/ \/ \/ \/
Val
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Namor » Ter Out 07, 2008 9:33 pm

Val escreveu:Hummm!!!! \/ \/ \/ \/



O q seria isso?
Namor
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor weslei » Ter Out 07, 2008 11:58 pm

Val escreveu:Hummm!!!! \/ \/ \/ \/



Também não entendi
weslei
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor sp4celan » Qua Out 08, 2008 9:15 pm

Estou a treis dias testado uma alteraçao feita pelo woshman, meu ping esta bem baixo e sem lentidao na navegaçao !
sp4celan
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor eduarley » Qui Out 09, 2008 7:19 am

sp4celan escreveu:Estou a treis dias testado uma alteraçao feita pelo woshman, meu ping esta bem baixo e sem lentidao na navegaçao !


Qual alteração ki vc fez post ai pra nois... :D
eduarley
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor nexus » Qui Out 09, 2008 9:52 am

Salve senhores,
Não tenho muita familiaridade com o bfw nem nada, mas estava fuçando no QOS (tentando entender) e achei uma coisa que me intrigou, como muito da discussão deste tópico esta envolvendo QOS, vou postar aqui novamente para ver se pode ajudar a resolver o problema da lentidao.

Fiz algumas alteraçoes no QOS via modulo QOS do webdmim, mudei faixa internet, distribuiçao da banda etc...
(salvei, backup, reboot etc, tudo conforme manda o figurino), após, fui editar o arquivo de configuraçao do QOS pela ferramenta de ediçao de configuração, fora do modulo QOS e me deparei com o arquivo com as configuraçoes diferentes das que eu fiz no webdmim.
Abri um post aqui no forum (problemas no QOS - tem a copia do meu arquivo de conf la) e me responderam que aquele arquivo era o arquivo padrao do coyote, bom, ele realmente não continha minhas mudanças estava igual a tela padrao do qos quando abrimos pela primeira vez.
A pergunta é, isso é um bug? Ou seja temos 2 arquivos de configs para o qos? Se for, será que os pacotes de navegacao nao estao passando 2 vezes no qos, gerando a dita lentidao?
Posso estar falando besteira, mas nao vejo o porque de termos 2 arquivos de configuraçao para a mesma coisa, independentes dentro do sistema.
Me corrijam e orientem, pois como falei sou novo na área e sou eng agronomo, ou seja pra mim é só um pouco mais difícil entrar nessa área...
Abraço a todos.
nexus
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Marcos do Vale » Qui Out 09, 2008 1:19 pm

Amigos,

Acho que encontramos a origem do problema de lentidão.
E o relato do nosso amigo NEXUS dá uma luz sobre o assunto.

Por coincidência hoje pela manhã cedo eu iniciei um debug geral nos scripts do qos.
Passei o sistema pra modo depuração, ou seja, os comandos são listados na tela em vez de executados.
O primeiro passo foi diretamente com o script de QOS em modo sub-redes (/etc/rc.d/rc.qos.subnet).
Primeira surpresa: o script rodava, mas sem as informações da classe JUNK!
Esta é uma informação gerada pelo script principal do QOS (/etc/rc.d/rc.qos).
Fui verificar o script. Localizei as linhas que geram os valores de JUNK (e uma série de outros valores):
Código: Selecionar todos
DOWNSTREAM_JUNK=$(percentage $QOS_DOWNSTREAM $QOS_DOWNSTREAM_JUNK)
UPSTREAM_JUNK=$(percentage $QOS_UPSTREAM $QOS_UPSTREAM_JUNK)
UP_FW_STREAM=$(percentage $QOS_UPSTREAM $QOS_UPFW_STREAM)
CLEAR_UPSTREAM=$((${QOS_UPSTREAM}-${UPSTREAM_JUNK}))
CLEAR_DOWNSTREAM=$((${QOS_DOWNSTREAM}-${DOWNSTREAM_JUNK}))
COMP_DOWN=$(percentage $CLEAR_DOWNSTREAM $QOS_DOWNSTREAM_INDIVIDUAL)
COMP_UP=$(percentage $CLEAR_UPSTREAM $QOS_UPSTREAM_INDIVIDUAL)


Como podemos ver, o valor de cada variável é definido pelo resultado da execução de uma função chamada "percentage" que recebe dois parâmetros.

Só que está função sumiu !
Eu já procurei nos scripts da versão 2.29 do BFW e não achei em nenhum lugar.
Pelo que notei, o nosso amigo NEXUS andou "tropeçando" nela em algum arquivo do QOS.
Se ele puder nos informações mais detalhadas sobre o que ele andou fazendo no BFW, talves possamos entender melhor o que aconteceu.

CORREÇÃO: Não sumiu. Está em /etc/qos.config.
Só que não sei por que o script do qos não consegue executar a função.

Bom, pra terminar, a solução:

Acrescentem as seguintes linhas a partir da linha 16 do arquivo /etc/rc.d/rc.qos:
Código: Selecionar todos
# counts bandwidth percentage, awoids zero results.
percentage () {
 res=$((${1}*${2}/100))
 [ $res -eq 0 ] && res=1
 echo $res
}

O trecho do arquivo ficará assim:
Código: Selecionar todos
iptables="/usr/sbin/iptables"
tc="/usr/sbin/tc"
ip="/bin/ip"

# counts bandwidth percentage, awoids zero results.
percentage () {
 res=$((${1}*${2}/100))
 [ $res -eq 0 ] && res=1
 echo $res
}

[ -e /tmp/netsubsys.state ] && . /tmp/netsubsys.state


Aguardo o resultado dos testes de vcs.
Editado pela última vez por Marcos do Vale em Qui Out 09, 2008 2:52 pm, em um total de 2 vezes.
Marcos do Vale
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Marcelo - Brazil » Qui Out 09, 2008 1:39 pm

!+ :aplause: :aplause: dancing :o!

Galera, um detalhe. Repare que TODA E QUALQUER experiencia e relato sobre um problema, podem realmente resolver o problema.
Ou seja, tudo que se faz e se diz é valido.

Valeu nexus você como engenheiro agronomo, será um ótimo linuxista ! \`´/ \`´/ \`´/
Valeu Marcos, tomara que isso resolva o problema !
BFW não é meu hobby, é meu router !
Não dou suporte.

"Nem sim, nem não, mas muito pelo contrário, não sou contra nem à favor,
porque em matéria de certas coisas o mais importante é o principalmente,
aliás inclusive, não resta a menor dúvida".
De algum politico brasileiro...
Avatar do usuário
Marcelo - Brazil
BFW Founder
BFW Manager
BFW Beneméritos
 
Mensagens: 3185
Registrado em: Qua Ago 24, 2005 10:40 pm
Localização: Campinas - São Paulo
BrazilFW Box: Hp Proliant ML30 Gen 9, Intel® Xeon® E3-1200 v5 3,0 Ghz, 8 Gb ram DDR4, 1 Tb HD, Links 120x12 mb/s cabo + 100x100 mb/s fibra. Addon: Unifi, 50 clientes lan + 50 cliente wireless.

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor nexus » Qui Out 09, 2008 1:47 pm

Marcos, pelamordedeus, nao "tropecei", tava tentando arrumar o meu bfw com meus parcos conhecimentos... :oops: .... \`´/
E achei estranho dois scripts versando pela mesma coisa em lugares diferente (inicializaçao e direto no QOS)... (Nao so minero, mas so desconfiado que só...)

Mas voltando a vaca fria, o script que descrevi acessei pela ediçao de arquivos de configuraçao no webdmin, editar aqruivo de configuraçao do QOS opção 13 link do browser (http://192.168.0.1:10000/cgi-bin/editco ... 0configuração%20QOS)
Segue abaixo o script!!


#!/bin/sh
# Coyote Traffic Control configuration file
# Author: Dolly <dolly@czi.cz>

QOS_DOWNSTREAM=1024
QOS_UPSTREAM=256

QOS_HIGH_PRI_PER=50
QOS_NORM_PRI_PER=35
QOS_SLOW_PRI_PER=15

QOS_FUP_BURST=8
QOS_NUP_BURST=4
QOS_SUP_BURST=2
QOS_FDOWN_BURST=16
QOS_NDOWN_BURST=8
QOS_SDOWN_BURST=4

QOS_UPFW_STREAM=10

QOS_UPSTREAM_INDIVIDUAL=25
QOS_DOWNSTREAM_INDIVIDUAL=25

QOS_UPSTREAM_JUNK=5
QOS_DOWNSTREAM_JUNK=5

# counts bandwidth percentage, awoids zero results. << linhas que estavam procurando
percentage () {
res=$((${1}*${2}/100))
if [ $res -eq 0 ]; then
res=1
fi
echo $res
}

build_class_chain () {
#Use the new qos.classes configuration file
. /etc/coyote/qos.classes

}

Abraços
nexus
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor medinale » Qui Out 09, 2008 2:00 pm

Bom fiz uns testes aqui, testei na máquina da assinatura.
Se entendi bem esta alteração resolveria o problema da lentidão, ou seja, a latência com o teste do ping diminuiria, quanto à isso não notei diferênça.
Lembrando que uso os scripts deste link viewtopic.php?f=2&t=65305
O ping continuou na mesma; se não for assim que devo proceder para o teste alguém me explique, abaixo o resultado do teste que fiz.

C:\Documents and Settings\Alessandro>ping 192.168.1.1 -l 65500

Disparando contra 192.168.1.1 com 65500 bytes de dados:

Resposta de 192.168.1.1: bytes=65500 tempo=228ms TTL=64
Resposta de 192.168.1.1: bytes=65500 tempo=227ms TTL=64
Resposta de 192.168.1.1: bytes=65500 tempo=236ms TTL=64
Resposta de 192.168.1.1: bytes=65500 tempo=235ms TTL=64

Estatísticas do Ping para 192.168.1.1:
Pacotes: Enviados = 4, Recebidos = 4, Perdidos = 0 (0% de perda),
Aproximar um número redondo de vezes em milissegundos:
Mínimo = 227ms, Máximo = 236ms, Média = 231ms

Obrigado à todos
medinale
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Marcos do Vale » Qui Out 09, 2008 2:06 pm

Eu que tropecei ... o script existe, a função tb existe ... só que não sei porque não é executada.
Marcos do Vale
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor celocao » Qui Out 09, 2008 2:20 pm

Fiz a alteração e aqui não surtiu efeito nenhum.....continua na mesma... \/
O tempo ficou entre 204 e 205ms com alteração ou sem alteração descrita !

Um abraço by celocao !+
celocao
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor luapufo » Qui Out 09, 2008 3:27 pm

celocao escreveu:Fiz a alteração e aqui não surtiu efeito nenhum.....continua na mesma... \/
O tempo ficou entre 204 e 205ms com alteração ou sem alteração descrita !

Um abraço by celocao !+

esta alterações nao influencia no ping e sim na demora na navegação, teste e reporte pra gente
luapufo
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor celocao » Qui Out 09, 2008 3:47 pm

ah bom......vou ver e depois digo o que aconteceu...sorry :mrgreen:

Um abraço by celocao
celocao
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor weslei » Qui Out 09, 2008 4:07 pm

celocao escreveu:Fiz a alteração e aqui não surtiu efeito nenhum.....continua na mesma... \/
O tempo ficou entre 204 e 205ms com alteração ou sem alteração descrita !

Um abraço by celocao !+



Pessoal, essa alteração não mudara o bug do ping, é para melhorar o desempenho da navegação do BFW, o problema do ping esta sendo corrigido com outra alteração que acho que deve ser postado em breve aqui no tópico.....

Abraço
weslei
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor nexus » Qui Out 09, 2008 4:10 pm

Senhores,
Outro detalhe que foi o que me fez abrir o tópico problema no qos.
No meu BFW, setei via webdmim a banda do link de up e download para 256 / 256 que é a velocidade do frame-relay que temos aqui.
No script constam os seguinte parametros:
QOS_DOWNSTREAM=1024
QOS_UPSTREAM=256

QOS_HIGH_PRI_PER=50
QOS_NORM_PRI_PER=35
QOS_SLOW_PRI_PER=15

E no arquivo mestre de inicializaçao do meu BFW consta as velocidades de up e down corretas:

QOS_UPSTREAM='256'
QOS_DOWNSTREAM='256'
QOS_FUP_BURST='8'
QOS_NUP_BURST='4'
QOS_SUP_BURST='2'
QOS_FDOWN_BURST='16'
QOS_NDOWN_BURST='8'
QOS_SDOWN_BURST='4'
QOS_DOWNSTREAM_INDIVIDUAL='25'
QOS_UPSTREAM_INDIVIDUAL='25'
QOS_DOWNSTREAM_JUNK='5'
QOS_UPSTREAM_JUNK='5'
QOS_UPFW_STREAM='80'
QOS_HIGH_PRI_PER='70'
QOS_NORM_PRI_PER='20'
QOS_SLOW_PRI_PER='10'

Estou achando estranho duas variaveis iguais com valores diferentes em diferentes scripts que interagem.
nexus
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor celocao » Qui Out 09, 2008 4:21 pm

Olha,não sei se é impressão minha,MAS PARECE QUE MELHOROU SENSIVELMENTE !!!!!!!!!!!! dancing
Há muito tempo estou usando a versão 2.31.10,não me lembro da velocidade do 2.30.1,mas a navegação melhorou muito depois dessa alteração.
As páginas estão abrindo mais rápido,numa "tacada"só,antes parecia que as páginas abriam em 3 partes,de cima pra baixo,primeiro em cima,depois no meio
e por ultimo o rodapé,deu pra perceber que isso mudou.

Será que já esta pintando o primeiro service pack pra versão 2.31.10 corrigindo a navegação e o tempo do ping.... ;-)

Um abraço by celocao :o!
celocao
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor nexus » Qui Out 09, 2008 4:45 pm

Celocao,

Por favor me tire uma duvida,

copie a parte do QOS do arquivo mestre de inicializaçao aqui para o post, bem como o arquivo de configuraçao do QOS que você encontra em Editar arquivos de configuraçao, configuraçao do QOS (opçao 13)

Ainda estou achando que o webdmin nao altera a variavel de download no arquivo de config do QOS, apenas no arquivo mestre.

MARCOS, Qual é a sequencia de inicializaçao do(s) scripts do QOS?
nexus
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor celocao » Qui Out 09, 2008 4:54 pm

BrazilFW Main Configuration File (opção 1)

IPUPDATE_TIMER='YES'
IPUPDATE_PAUSE='600'
IPUPDATE_EXTERNALIP='NO'
DYNDNS_UPDATE='NO'
NOIP_UPDATE='YES'
NOIP_DOMAIN='xxxxxxx'
NOIP_EMAIL='xxxxxxx'
NOIP_PASSWORD='xxxxxx'
DYNSERV_UPDATE='NO'
ZONEEDIT_UPDATE='NO'
INETTYPE='PPPOE'
LOCAL_IPADDR='192.168.0.1'
LOCAL_NETMASK='255.255.255.252'
LOCAL2_IPADDR='172.16.0.1'
LOCAL2_NETMASK='255.255.255.252'
LOCAL3_IPADDR='10.0.0.1'
LOCAL3_NETMASK='255.255.255.252'
PPPOE_USERNAME='xxxxx'
PPPOE_PASSWORD='xxxxx'
PPPOE_IDLE='NO'
DHCPSERVER='YES'
DHCPD_START_IP='192.168.0.2'
DHCPD_END_IP='192.168.0.2'
DHCPD_LEASE='900'
ADMIN_AUTH='xxxxxxxxxxxxxxxxxxxxx'
IF_LOCAL='eth0'
IF_INET='eth1'
IF_LOCAL2='eth2'
IF_LOCAL3='eth3'
TZ='EST4EDT'
USE_DNS_CACHE='YES'
ENABLE_CRON='YES'
QOS_TYPE='SUBNET'
QOS_UPSTREAM='1024'
QOS_DOWNSTREAM='5120'
QOS_FUP_BURST='8'
QOS_NUP_BURST='4'
QOS_SUP_BURST='2'
QOS_FDOWN_BURST='16'
QOS_NDOWN_BURST='8'
QOS_SDOWN_BURST='4'
QOS_DOWNSTREAM_JUNK='5'
QOS_UPSTREAM_JUNK='5'
QOS_UPFW_STREAM='10'
QOS_HIGH_PRI_PER='50'
QOS_NORM_PRI_PER='35'
QOS_SLOW_PRI_PER='15'
DEFAULT_USERS_FILTER='BLOCK_ALL'
DEFAULT_SERVICES_FILTER='ALLOW_ALL'

QOS Config File (opção 13)

#!/bin/sh
# Coyote Traffic Control configuration file
# Author: Dolly <dolly@czi.cz>

QOS_DOWNSTREAM=1024
QOS_UPSTREAM=256

QOS_HIGH_PRI_PER=50
QOS_NORM_PRI_PER=35
QOS_SLOW_PRI_PER=15

QOS_FUP_BURST=8
QOS_NUP_BURST=4
QOS_SUP_BURST=2
QOS_FDOWN_BURST=16
QOS_NDOWN_BURST=8
QOS_SDOWN_BURST=4

QOS_UPFW_STREAM=10

QOS_UPSTREAM_INDIVIDUAL=25
QOS_DOWNSTREAM_INDIVIDUAL=25

QOS_UPSTREAM_JUNK=5
QOS_DOWNSTREAM_JUNK=5

# counts bandwidth percentage, awoids zero results.
percentage () {
res=$((${1}*${2}/100))
if [ $res -eq 0 ]; then
res=1
fi
echo $res
}

build_class_chain () {
#Use the new qos.classes configuration file
. /etc/coyote/qos.classes

}

Detalhe : LINK GVT 5 mega down/ 1 mega up,postei os arquivos certos ? é isso que era preciso ? :o!
Para cada cliente eu dou 1 mega de down e 512 de upload - valores máximos

OBS: Foi realizada a alteração solicitada,feito backup e reinicializada a máquina pra não dar erro e somente depois disto postei as configurações que pediram,só pra esclarecer como foi feito o procedimento.
celocao
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Marcos do Vale » Qui Out 09, 2008 7:03 pm

nexus escreveu:Celocao,

Por favor me tire uma duvida,

copie a parte do QOS do arquivo mestre de inicializaçao aqui para o post, bem como o arquivo de configuraçao do QOS que você encontra em Editar arquivos de configuraçao, configuraçao do QOS (opçao 13)

Ainda estou achando que o webdmin nao altera a variavel de download no arquivo de config do QOS, apenas no arquivo mestre.

MARCOS, Qual é a sequencia de inicializaçao do(s) scripts do QOS?

Srs,

Por favor respeitei o fórum.
Este post é EXCLUSIVO para resolvermos os problemas apresentados pela versão 2.31.10.
Problemas individuais terão mais sucesso na obtenção de ajuda na medida em que forem abertos post específicos.
Agradeço a compreensão.
Marcos do Vale
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor celocao » Qui Out 09, 2008 11:11 pm

Olha Marcos,de coração te digo que postei a configuração que o nexus pediu no intuito de ajudar a resolver essa questão do problema de velocidade....

Desculpe se fui mau interpretado... ^/

Um abraço by celocao
celocao
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Marcos do Vale » Sex Out 10, 2008 8:21 am

Sei que a intenção de todos aqui é ajudar.
Mas temos que manter um pouco de foco em determinados assuntos, senão a coisa vira uma zona.
Marcos do Vale
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor wimigasltda » Sex Out 10, 2008 7:42 pm

Aff... que coisa>
wimigasltda
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Zatar » Sex Out 10, 2008 11:53 pm

Marcos, sobre a alteração em /etc/rc.d/rc.qos:, por você proposta, aqui surtiu efeito. :o! :o!
Zatar
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Namor » Sáb Out 11, 2008 3:10 pm

Zatar escreveu:Marcos, sobre a alteração em /etc/rc.d/rc.qos:, por você proposta, aqui surtiu efeito. :o! :o!



Zatar se puder dar mais detalhes do que melhorou acho q ajudaria mais, vc notou diferença na navegação?

Amanhã de manhã mudarei da 2.30.1 para a 2.31.10 e farei este teste amanhã atarde terei uma resposta para este tópico.
Namor
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor wimigasltda » Sáb Out 11, 2008 3:34 pm

Fiz estas alterções aqui, deu parece que ficou a mesma coisa.
Estamos ai na busca da soluçao.
Pra minha rede que é grande,e toda wirelles: em testes, o bfw anterior ainda se sai mais rapido em todos quisitos navegação.

:o!
wimigasltda
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Namor » Sáb Out 11, 2008 5:49 pm

wimigasltda escreveu:Fiz estas alterções aqui, deu parece que ficou a mesma coisa.
Estamos ai na busca da soluçao.
Pra minha rede que é grande,e toda wirelles: em testes, o bfw anterior ainda se sai mais rapido em todos quisitos navegação.

:o!


é uma pena, mas foi muito boa a intenção do Marcos do Vale de colocar o BFW em mode debug para verificar o erro e tentar-mos resolver.

Farei este teste amanhã de manhã. :o!
Namor
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Namor » Dom Out 12, 2008 5:14 pm

alexmax escreveu:amigos, estou tentando ajudar a encontrar o erro revendo os arquivos... não sei se tem alguma coisa haver,
mas estive observando o arquivo (/etc/rc.d/rc.masquerade) e notei que na linha #63 há um erro

está assim:
# [ ! -z $LOCAL4_IPADDR ] && masquerade $LOCAL4_IPADDR $LOCAL2_NETMASK

para cumprir com a sequencia correta do ipaddr, deveriamos trocar o utimo número que no final está "2", pelo "4"
ficando assim:
# [ ! -z $LOCAL4_IPADDR ] && masquerade $LOCAL4_IPADDR $LOCAL4_NETMASK


abraços


Alexmax, poderia dar mais informações sobre o q influencia esta alteração.
Namor
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor Marcos do Vale » Seg Out 13, 2008 8:22 am

Este BUG já foi reportado em 02/09/08.
viewtopic.php?f=22&t=65980

Aliás, é lá o local correto para este tipo de post.
Marcos do Vale
 

Re: Bug da lentidão do 2.31.10! Algum Developer afim de Ajudar?

Mensagempor eduarley » Seg Out 13, 2008 9:15 am

então esta resolvido?
e so mudar isto ki o bug ja era?
alguem ja testo?
eduarley
 

AnteriorPróximo

Voltar para BrazilFW 2.x - Ajuda em Geral (Todas as Línguas)

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 7 visitantes